Important announcement about Slate Desktop installation

Dear Slate users:

 * ALL INSTALLERS BEFORE UPDATE 1.4.1 NOT WORK.
 * YOU MUST UPDATE TO 1.4.1 OR NEWER TO INSTALL/REINSTALL/UPDATE YOUR SLATE PRODUCTS.


Here are the details:

We updated our website and restored the "slate.rocks" domain. We like it because it's catchy, but we had to take it down because there were spam and security problems.

We worked with our hosting service and fixed those problems. Now it's back with some security enhancements. These new updates make our online store more secure for everyone because we implement a "secure sockets" (SSL/HTTPS protocol).

A necessary byproduct of this enhanced security affects your license authentication experience. The installer validates your license key by communicating with our website.

Our switch to HTTPS means all installers before the 1.4.1 update will no longer work. You must update to the newest installer to re-install Slate on any machine. Our updated site also has a customer dashboard page with your download links.

https://slate.rocks/my-dashboard/

You can also check the status of your purchases and update your account information.

I apologize for the inconvenience that this security update imposes on all of you. In the long run, I believe, however, that the secure experience benefits everyone. Thank you for your understanding and cooperation.

Best regards,
Tom

P.S. I've done my best to test and verify these updates work for everyone, but the web environment can be different for everyone. As always, I will be available in over-time to help anyone should you experience and unexpected update problems.

1 person likes this
Login or Signup to post a comment